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After completing this lesson, you will 

be able to: 

  

OFFICE AUTOMATION 

 
 

UNIT INTRODUCTION 

Computer users have to prepare documents in whichever profession they are. It is 

essential for all the users to learn how to create documents such as letters, reports, proposals, 

resumes, etc. Spreadsheets are also commonly required in business and office. These are used 

to store and process numeric data. Hence, all the users should have basic knowledge to create 

documents and spreadsheets. This unit describes how to prepare professional-looking 

documents and spreadsheets using a word processing and a spreadsheet program respectively. 

The last section of the unit describes how to prepare documents in Urdu with an Urdu editor. 
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DO YOU KNOW? 

Microsoft Office 2010 cannot 

be installed on a computer on 

which Windows XP operating 

system is installed. 

3.1 OFFICE AUTOMATION 

Office Automation refers to modern technology used to create, store, process and 

communicate information for accomplishing basic tasks performed in offices. The system that 

facilitates office automation is known as Office Automation System (OAS). Office Automation 

System consists of computer hardware, software and network. The software used for office 

automation consists of word-processing, spreadsheet, database management, presentation, 

graphics, electronic mail and video conferencing software. Office automation software allows 

users to create letters, reports, spreadsheets, graphs, manipulate images and send email to or 

receive email from users on the network. Office automation software helps in improving 

productivity and saving money and human efforts. 

The most commonly used office automation software is Microsoft Office. It is an office suite 

of applications. It consists of MS Word, MS Excel, MS Access, MS PowerPoint and MS Outlook. 

It was first announced by Bill Gates on 1 August 1988. Its latest version is Microsoft Office 2016 

released on 22 September, 2015. It is also operateable in Urdu. 

Some other examples of office automation software are Apache OpenOffice, LibreOffice 

and NeoOffice. All of these are based on OpenOffice office suite. These can be freely 

downloaded and installed on Windows, Linux and MacOS operating systems. 

3.1.1 INSTALLATION OF OFFICE AUTOMATION SOFTWARE 

The common office automation software is Microsoft Office. It is productivity software for 

Windows operating system. It includes word processing, spreadsheet, presentation, database 

and e-mail communication programs. These programs provide facilities that are commonly 

required to run an office or business. 

The following are the steps to install Microsoft Office 2010 software. 

1. Run the installation program. 

2. Enter the Product Key and 

click Continue button as 

shown in Fig.3-1. 

3. Read the Microsoft Software 

License Terms shown in 
 

 
  Fig.3-1 Screen for entering Product Key  

https://en.wikipedia.org/wiki/Bill_Gates
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Fig.3-2, check the box to accept the terms of agreement and click Continue. 

 

  Fig.3-2 Microsoft Software License Terms  
 

 

4. Click Install Now button shown in Fig.3-3 to start the installation. 
 

  Fig.3-3 Screen to choose preferred type of installation  
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DO YOU KNOW? 

The first version of Microsoft Word was released in 1983 for DOS and 

first Windows version was released in 1989. 

5. Progress bar indicating how much installation has progressed will appear as shown in Fig.3- 

4. This may take several minutes to complete. 

 

  Fig.3-4 Progress bar indicating installation progress  
 
 

6. Click the Close button shown in Fig.3-5 to exit the installation program. 

  Fig. 3-5 Screen indicating that installation has completed  
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Fig.3-6 Opening Word 

Word processing refers to the use of computer to create, edit, format and print 

documents. 

Word processor is computer application software that is used for the creation of different 

types of documents on computer. 

Word processor is a commonly used application of computer. Word processor allows user to 

delete, modify and rearrange document without retyping any of the existing text. Word processing 

system has the advantage of reducing time required to prepare documents. It provides features to 

create appealing  professional 

documents. With word processing 

programs, user can create many 

types of documents such as letters, 

reports, resumes, newsletters, 

memos, flyers, etc. 

A common word processing 

program used is Microsoft Word. It 

is a part of Microsoft Office 

software. Microsoft Office contains 

word processing, record-keeping, 

spreadsheet and presentation 

software. 

Opening the MS Word Program 

The following are the steps for 

opening the MS Word program. 

1. Turn on the computer and 

click Start button. 

2. Click All Programs. 

3. Click Microsoft Office to 

display the submenu. The 

submenu contains all the 

programs included in Microsoft 

Office software. 

 
4. Click Microsoft Word 2010 to 

open the Word program shown in 

Fig.3-6. 
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Word Window 

The main components of Word window consist of Quick Access Toolbar, Ribbon, Horizontal / Vertical 

Scroll bars and Status bar as shown in Fig.3-7. 

Quick Access Toolbar 

Quick Access Toolbar is located at the top left corner of Word window. It provides easy 

access to commonly used Save, Undo and Redo commands. If the user clicks the down arrow 

at the right side, Word will display a list of commands that can be quickly added to or removed 

from the Quick Access Toolbar. 

Ribbon 

Ribbon is located below the title bar of the Word window. Ribbon consists of tabs, groups 

and commands as shown in Fig.3-8. It provides access to the commands that are performed 

while working on a document. 

There are nine types of tabs in the ribbon which are File, Home, Insert, Page Layout, 

References, Mailings, Review, View and Add-Ins. Home tab is the most commonly used tab. To 

display any of these tabs just click on it. 

Fig.3-7 Word Window 
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  Fig.3-8 Ribbon  

 

Horizontal and Vertical Scroll Bars 

Vertical scroll bar is located at the right edge of the document window. It is used to scroll 

down or up the document that is too large to fit in the document window. Horizontal scroll bar 

appears automatically at the bottom of the document window if a document is too wide to fit in 

the document window. 

Status Bar 

Status bar is located at the bottom of the document window above the Windows task bar, 

It presents information about the document such as current page, total number of pages in the 

document, number of words in the document, etc. It also provides controls for viewing the 

document in different layouts. The right edge of status 

bar presents zoom in and zoom out bar. Zoom in is 

used to get close-up view of document and zoom out 

is used to view more of the page at a reduced size. 

3.1.2 MANAGING A DOCUMENT 

Creating a New Document 

The following are the steps to create a new document. 

1. Click the File tab. 

2. Click New in the pull-down menu as shown in 

Fig.3-9. 

3. Select Blank document which is below 

Available Templates. User can also start a new 

document by selecting a template. 

  Fig.3-9 File tab  4. Click Create. A new blank document will appear 
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Another way to start a new blank document is press Ctrl+N on the keyboard. Ctrl+N means 

keep pressing the Ctrl key while pressing the N key. 

Opening a Document 

1. Click the File tab 
 

  Fig.3-10 Open dialog box  
 
 

2. Click Open. The Open dialog box as shown in Fig.3-10 will appear. 

3. Select the document and click Open. 

If the user has recently opened the document that he wants to open then he can follow the 

steps given below. 

1. Click File tab. 

2. Click Recent. 

3. Select the document from the Recent Document list. 

Saving a Document 

1. Click File tab. 

2. Click Save or Save As. 

3. Select the folder where the document is to be saved as shown in Fig.3-11. 

4. Give a file name to your document. 
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Save icon 

 

 
 

  Fig.3-11 Save As dialog box  

5. Click Save. 
 

 

 

 

  Fig.3-12 printing a document  

Save As option is used when changes have been made 

in an existing file and the user wants to save the new 

version of the document with a different file name. 

Another way to save a document is, click the Save icon 

on the Quick Access Toolbar and give the new document 

a file name. 

Printing a Document 

The following are the steps to print a document. 

1. Click the File tab. 

2. Select Print. 

3. Change the print settings shown in Fig.3-12 if 

required and click Print. 
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Tip: To search text in a 

document, press Ctrl+F, 

type the search text in the 

box and press Enter. 

3.1.3 INSERTING AND EDITING TEXT 

To insert text in a document, type it using the keyboard. The text will appear at the insertion 

point. When typing a paragraph, there is no need to press the Enter key at the end of the line. 

When the user reaches the right margin, Word will automatically position the insertion point at 

the beginning of the next line. The user should only press the Enter key when he wants to end 

a line of text, start a new paragraph or insert a blank line. Shortcut keys for cursor movement 

are shown in Table 3-13. 
 

Cursor Movement Shortcut Key 

Beginning of the line Home 

End of line End 

Top of the document Ctrl + Home 

End of document Ctrl + End 

  Table 3-13 Shortcut keys for cursor movement  

 

Selecting Text 

To move or copy words, sentences or paragraphs to another 

location in the document, first select the text and then use cut-and- 

paste or copy-and-paste technique. Commands shown in Table 3- 

14 are used for selecting various items in a document with mouse. 

 

Item to Select Mouse Command 

Characters Drag through characters 

Single word Double-click the word 

Words Drag through words 

Sentence Press and hold down Ctrl key and click anywhere in the sentence 

Line 
Move the mouse pointer to the left of the line until it changes to a right- 

pointing arrow and then single click 

Paragraph 
Move the mouse pointer to the left of the paragraph until it changes to a 

right-pointing arrow and then Double-click 

Entire document 
Move the mouse pointer to the left of the document until it changes to a 

right-pointing arrow and then triple-click 

 
Block of text 

Click at the beginning of the text to be selected. Move the mouse 

pointer to the end of the selection and hold down Shift key and then 

click or drag through the text. 

Graphic Click the graphic 

  Table 3-14 Mouse commands for selecting items  
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Copying and Moving Text 

The following are the steps to copy or move the first two sentences of the paragraph shown 

in Fig.3-15. 

  Fig.3-15 Paragraph in Word window  
 

 

1. Select the text that is to be copied or moved as shown in Fig.3-16 

 

  Fig.3-16 Text selected for copying  
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2. Click Copy or Cut in the Clipboard group of Home tab as shown 

above. 

3. Position the mouse pointer at the location where you want to copy 

or move the text. 

4. Click Paste in the Clipboard group. Copied text is shown in Fig.3- 

17. 
 

 

  Fig.3-17 Text copied at the end of paragraph after leaving one blank line  
 
 

There is another method for copying and moving text using shortcut keys. The steps for 

this are given below. 

1. Select the text. 

2. Press Ctrl+C for copying or Ctrl+X for moving text. 

3. Position the mouse pointer to the location where you want to copy or move the text. 

4. Press Ctrl+V for pasting the text. 

There is also a third method for copying and moving text. The following are the steps for 

this method. 

1. Select the text as shown in Fig.3-18. 
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Arrow to Minimize/Maximize 
Ribbon 

 

 

  Fig.3-18 Shortcut menu for copying or moving text  
 

 

2. Right click anywhere inside the selected text to display the shortcut menu. 

3. Click Copy or Move in the shortcut menu as shown in Fig.3-19 

4. Move the mouse pointer where you want to copy or move the text. 

5. Right click and then click Paste in the shortcut menu. 

Deleting Text 

To delete text, select the text using any of the methods described earlier and then press 

Delete key. 

3.1.5 MINIMIZE/MAXIMIZE RIBBON 
 

  Fig.3-19 Minimizing or maximizing Ribbon  
 

 

To minimize the Ribbon for more screen space, click the arrow in the upper-right corner 

of the Ribbon as shown in Fig.3-19. When Ribbon is minimized, click on a tab to display it. The 

Ribbon will disappear again when it is not in use. To maximize the Ribbon, click the arrow 

again. 
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3.1.6 INSERTING SYMBOLS 

The following are the steps to insert symbols or special characters in documents. 
 

  Fig.3-20 Inserting symbols in document  
 

 

1. Click Insert tab. 

2. Click Symbol which is at the right end of ribbon. A group of symbols will be displayed as 

shown in Fig.3-20. 

3. Click the symbol that is to be inserted in document. The symbols will be inserted in the 

document as shown in Fig.3-21. 
 

  Fig.3-21 Symbols inserted in document  
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To display more symbols, click More 

Symbols in the Symbol menu. A new 

dialog box will open with two tabs, 

Symbols and Special Characters as 

shown in Fig.3-22. Now, select the symbol 

and click the Insert button. 

 

 

 
 
 

 
  Fig.3-22 Symbol dialog box  

3.1.7 INSERTING EQUATION 

Word allows user to insert common 

mathematical equations or build up his own 

equations using a library of symbols. 

The following are the steps to insert built- 

In equation. 

1. Click Insert tab. 

2. Click Equation button on the 

Symbols group. 

3. Select the type of equation you 

want to insert as shown in Fig.3-23. 

To following steps allow the user to insert 

his/her own equation. 

1. Click Insert tab. 

2. Click π button on the Symbols 

group. This will open the Design tab 

shown in Fig.3-24 that allows inserting 

common mathematical equations or build 

equation using a library of math symbols. 
 
 

 

  Fig.3-23 Inserting equation  

 

  Fig.3-24 Design tab for inserting equation  
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3.1.8 FORMATTING TEXT, PARAGRAPH AND PAGE 

Formatting Text 

Formatting text means changing the font type, size, style, color and effects of text. 

Changing the Font Type and Size of Text 

Open the Home tab 

and click the arrow on the 

right side of the currently 

selected font type as 

shown in Fig.3-25 and 

choose another font type. 

To change the font size, 

click the arrow on the 

right side of the font size 

and select a font size 

from the drop-down list or 

Font type Font size 
 

 

  Fig.3-25 Changing font type and font size  

type a new font size. To change the font type or size of existing text, select the text and 

then make the changes. 

Changing Font Styles and Effects 

The following are the steps for changing 

font styles and effects. 

1. Click the Home tab. 

2. Click the dialog box launcher on the 

lower-right corner of the Font group. 

This will open the Font dialog box 

shown in Fig.3-21. Now, the user can 

change font styles and effects of text. 

Some changes that are available in 

the Font dialog box can be made directly 

from the Font group in Home tab. 

The following are the steps to clear the text 

formatting. 

1. Select the text you want to clear the 

formatting. 

2. Click the Home tab. 

3. Open the Styles dialog box and select 

Clear all as shown in Fig.3-26. 
  Fig.3-26 Font dialog box  
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  Fig.3-27 Style dialog box  
 

 

Paragraph Formatting 

Paragraph formatting refers to change of format of text of paragraph such as font size, 

color, line spacing, alignment etc. Paragraph formatting tools are provided in the Paragraph 

group of Home tab as shown in Fig.3-27 and Page Layout tab. 

 Changing Paragraph Alignment and Indenting 
 

 

  Fig.3-28 Paragraph alignment and indenting  

Paragraph alignment refers to the 

appearance of lines in a paragraph in relation 

to left or right margins. Left align is the default 

setting for paragraph alignment. 

Paragraph indentation refers to the 

distance of paragraph from left margin. 

Select the paragraph to change the 

alignment and then select an alignment from 

the Paragraph group on Home tab as shown 

in Fig.3-28. 

 

Align left: It will align the text to the left margin. 

Center: It will center the text within the left and right margins. 

Align right: It will align the text to the right margin. 

Justify: It will align the text both to the right and left margins. 
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Fig.3-30 Page Layout tab 

To increase paragraph indent, click 

the Increase Indent button shown in 

Fig.3-23, in the Paragraph group on 

Home tab. To decrease the paragraph 

indent, click the Decrease Indent button. 

Increasing indentation will move the 

paragraph to the right side by one tab 

position. Decreasing indentation will move 

the paragraph to the left side by one tab 

position. 

 Changing Spacing between 

Paragraphs and Lines 

The following are the steps for changing 

spacing between paragraphs and lines. 

1. Select the paragraph or paragraphs. 

2. Click Home tab. 

3. Open the Paragraph dialog box 

shown in Fig.3-29 by clicking the 

small arrow at the bottom right corner 

of the Paragraph group. 

4. Make the required changes. 

5. Click OK to apply the changes. 

Page Formatting 

Page formatting refers to formatting 

 

 

  Fig.3-29 Paragraph dialog box  

that affects the entire page such as changing page orientation, margins, page numbering, 

header and footer, etc. Page formatting commands are included in the Page Layout tab on the 

Ribbon. These are in the Themes, Page Setup and Page Background groups as shown in 

Fig.3-30. 

Commonly used page formatting commands include changing theme, margins, orientation, 

page size and background. 
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 Document Theme 

Themes change the overall appearance of the entire document, including colors, fonts 

and effects. 

The following are the steps to apply a theme. 

1. Click the Page Layout tab. 

2. Click the Themes button in the Themes 

group. 

3. Select a theme to apply from the menu 

shown in Fig.3-31. If the user does not like 

the selected theme, he can select another 

one. To remove a theme from the 

document select Office theme. 

 Page Margins 

Page Margins refer to the amount of 

blank space that appears at the top, bottom, left 

and right edges of a document. 

  Fig.3-31 Applying a theme to a document  

1. Click the Page Layout tab. 

2. Click Margins button. 

The following are the steps to set margins. 

3. Select margins from the menu that appears as shown in Fig.3-32. 
 

  Fig.3-32 Setting page margins  
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 Page Orientation 

Page orientation refers to the 

way rectangular page is oriented 

for viewing. There are two types of 

page orientations which are portrait 

and landscape. In portrait 

orientation, the height of display is 

greater than width. In landscape 

orientation, the width of display is 

greater than height. 

The following are the steps to 

apply a page orientation. 

1. Click Page Layout tab. 

2. Click Orientation button in the 

Page Setup group. 

 

 

  Fig.3-33 Applying page orientation  

3. Select Portrait or Landscape orientation as shown in Fig.3-33 

 Page Size 

Page size refers to the height 

and width of page. 

The following are the steps to 

set page size. 

1. Click Page Layout tab. 

2. Click Size button in the Page 

Setup group. 

3. Select a page size from the 

menu shown in Fig.3-34. 

 Page Background 

The Background group has 

three items to set for the document 
  Fig.3-34 Selecting a page size  

which include Watermark, Page Color and Page Borders. Watermark inserts dim text behind 

the content of the page. Page Color sets the page background color and Page Borders option 

inserts or changes the border around the page. 

The following are the steps to set watermark 

1. Click Page Layout tab. 

2. Click Watermark command in the Page Background group. 
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Fig.3-35 Creating a watermark 

3. Click Custom Watermark from the menu shown in Fig.3-35. User can also select a 

watermark that is displayed in the menu if it fulfills the requirement. 
 

4. Type the text for watermark as shown in Fig.3-36 

5. Click Apply and then click Close to close the dialog box. 
 

  Fig.3-36 Dialog box to create watermark  
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The following are the steps to set page color. 

1. Click Page Layout tab. 

2. Click the Page Color command. 

3. Select a page color from the menu shown 

in Fig.3-37 

The following are the steps to set page 

border. 

1. Click Page Layout tab. 

2. Click the Page Borders command in 

Page Background group. 

3. Select a page border style from the 

Borders and Shading dialog box shown 

in Fig.3-38 

3.1.9 INSERTING PAGE BREAKS 

AND SECTION BREAKS 

A page break is a marker that tells 

Word program that the contents which follow 

are to appear on a new page. Word 

automatically inserts a page break when the 

user reaches the end of a page. Page break 

is inserted in document when user wants to 

add a new page to the document. 

A section break also inserts a new page 

 

 

  Fig.3-37 Setting a page color  
 

  Fig.3-38 Selecting a page border style  

but it allows the user to change the page format without having any effect on the formatting of 

the previous pages. For example, section break can be 

used to break a document into sections having different 

header and footer for each chapter of a book. 

The following are the steps for inserting page break and 

section break. 

1. Click the Page Layout tab. 

2. Click the Breaks icon to open the drop-down menu 

shown in Fig.3-39. 

3. To insert a page break click the first option under the 

Page Breaks heading and to insert a section break 

click the first option under the Section Breaks 

heading. 
  Fig.3-39 Breaks drop-down menu  
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3.1.10 INSERTING HEADER, FOOTER AND PAGE NUMBER 

Header refers to information that appears at the top of a page and 

footer refers to information that appears at the bottom of a page. The type 

of information that may 

appear in the header or 

footer  includes  book title, 

document title, chapter number and title, page 

number, company name, etc. 

The following are the steps for inserting header or 

footer. 

1. Click the Insert tab. 

2. Click the Header or Footer in the Header & 

Footer group shown above to open the 

drop-down menu. 

3. Select a predesigned header or footer from 

the drop-down menu shown in Fig.3-40. 

Header or footer will appear in the document 

and the Design tab will appear in the 

Ribbon as shown in Fig.3-41. 

4. Type the information in the header or footer. 

5. After entering the information, click Close 

Header and Footer in the Design tab. 
  Fig.3-40 Inserting a header  To edit the information in the header or footer 

Double-click anywhere on the header or footer and make the changes. 
 

 

  Fig.3-41 Entering information in header  
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Inserting Page Numbers 

The following are the steps for 

inserting page numbers in 

documents. 

1. Click the Insert tab. 

2. Click Page Number in the Header 

& Footer group. A drop-down 

menu will appear. 

3. Move the mouse pointer on Top of 

Page or Bottom of Page 

command. This will open a 

submenu as shown in Fig.3-42. 

4. Select an option from the 

submenu. Page number will be 

inserted in the document and 

Design tab will appear on the 

Ribbon. 

5. Set the value for Header from Top 

or Footer from Bottom in the 

Position group of Design tab if 

required. 

 

 

  Fig.3-42 Inserting page number at the bottom of page  

6. Click the Close Header and Footer button on the Design tab. 

3.1.11 INSERTING AND POSITIONING PICTURE 

The following are the steps 

for inserting a picture in a 

document. 

1. Place the cursor where 

to insert the picture. 

2. Click Insert tab. 

3. Click Picture command 

in Illustrations group. 

The Insert Picture 

dialog box will appear 

as shown in Fig.3-43. 

4. Browse and select the 

picture file to insert and 

click Insert button. 

  Fig.3-43 Insert Picture dialog box  
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Fig.3-44 Positioning a picture within a page 

Positioning Picture within a Page 

The following are the steps for positioning picture on page. 

1. Click the picture that is to be positioned. Format tab will appear on 

the screen. 

2. Click Position command on the Arrange group. 

3. Select a position from the menu. Top right corner is selected for 

positioning the picture in Fig.3-44. 
 

4. Picture positioned at top right corner of page is shown in Fig.3-45. 

 

  Fig.3-45 Picture positioned at top right corner of page  

Tip: If you want to 

change the page 

number format, click 

Insert tab then click 

Page Number and 

select Format Page 

Numbers. 
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3.1.12 INSERTING WORDART 

WordArt is a text modifying feature in Word to 

create decorative effects such as shadow, colors, 

outlines, 3D effects, changing shape of text, etc. as 

shown in Fig.3-46. It is also 

possible to convert existing 

text into WordArt. 

The following are the steps to 

insert WordArt in a document. 

1. Click the Insert tab. 

2. Click WordArt in the Text 

group. 

3. Select character style from 

the drop-down menu 

shown in Fig.3-47. Format 

tab will appear on the 

Ribbon. 

4. Type the text in the text 

 

 

  Fig.3.46 Text created with WordArt  

box shown in Fig.3-48.   Fig.3-47 Inserting WordArt  

 
 
 

 

  Fig.3-48 Entering text in WordArt  
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Tip: Another way to insert table is, click 

Insert tab, click Table and then select 

Insert Table. Specify the number of 

rows and columns in the dialog box and 

click OK. 

5. Click Text Effects command in the WordArt Styles group. 

6. Move the mouse pointer over Transform and select a text effect from the submenu as shown 

in Fig.3-49. 
 

 

3.1.13 CREATING AND FORMATTING TABLE 

A table consists of rows and columns. The intersection of a row and a column is called a 

cell. Text is entered in the cells. Before inserting a table in a document, user should know the 

number of rows and columns required. This is called the dimension of the table. User can easily 

add more rows or columns as required. In table dimension, the first number is the number of 

columns and the second number is the number of rows. For example, a 5x4 (five by four) table 

means it has 5 columns and 4 rows. 

Inserting Table in a Document 

The following are the steps for inserting a 5x4 table. 

1. Click Insert tab. 

Fig.3-49 Applying text effect 
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2. Click Table command in the Tables group as shown in Fig.3-50. 
 

  Fig.3-50 Inserting a 5x4 table in a document  
 

3. Position the mouse pointer on the cell in the fourth row and fifth column and click. A blank 

table consisting of 4 rows and 5 columns will be inserted in the document. 

4. Now, user can enter data in the cells. 

A 5x4 table with data is shown in Fig.3-51. 

Fig.3-51 Data entered in a 5x4 table 
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Adding and Deleting Rows or Columns 

The following are the steps for adding and deleting rows or columns. 

1. To insert a row, click in the cell below or above which a blank row is to be inserted. To insert 

a column, click in the cell to the right or left of which a blank column is to be inserted. Design 

and Layout tabs will appear on the Ribbon. 

2. Click the Layout tab. 

3. Click the command in the Rows & Columns group shown in Fig.3-52 to insert a row or 

column. If you want to delete a row or column click the Delete command in the Rows & 

Columns group. Select the Delete Rows or Delete Columns from the drop-down menu. 

User can also delete the entire table by selecting Delete Table. 

User can delete multiple rows or columns by selecting them by dragging and then clicking 

the Delete command. 
 

  Fig.3-52 Adding or deleting rows and columns  
 

Resizing Rows and Columns 

Following are the steps for resizing row or columns. 

1. Click in any cell of row or column to change the height or width. 

2. Click Layout tab as shown in Fig.3-53. 
 

  Fig.3-53 Resizing row and column size  
 

3. Resize row height or column width in the Cell Size group. 

To resize multiple rows or columns, first select multiple rows or columns. Last three rows 

of table are selected for resizing in Fig.3-54. Table after resizing the last three rows is shown in 

Fig.3-55. 
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  Fig.3-54 Selection of multiple rows for resizing  
 

  Fig.3-55 Table after resizing the last three rows  
 

Adding or Changing Border Lines and Shading 

The following are the steps for adding or changing border lines and shading. 

1. Select the cells 

2. Click the Design tab. 

3. Open the Border drop-down menu in the Table Styles group and select a border as shown 

in Fig.3-56. 
 

  Fig.3-56 Changing border lines of a table  
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4. For shading, open the Shading drop-down menu in the Table Styles group and select a 

shading color as shown in Fig.3-57. 
 

  Fig.3-57 Selecting a shading color for a table  

 

Merging and Splitting Cells 

1. Select the cells for merging or splitting. 

2. Click the Layout tab. 

3. Click Merge Cells command in the Merge group as shown in Fig.3-58. Table after merging 

the selected cells is shown in Fig.3-59. For splitting cells, click the Split Cells command in 

the same group and enter required values in the Split Cells dialog box and click OK. 
 

  Fig.3-58 Selecting cells for merging  
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  Fig.3.59 Table after merging two cells  

3.1.14 CHANGING MARGINS 

The following are the steps for changing margins. 

1. Click Page Layout tab. 

2. Click Margins in the Page Setup group. 

3. Select margins from the drop-down menu as shown in Fig.3-60 or click Custom Margins 

and set the required margins in the Margins tab of Page Setup dialog box. 

4. Click OK. 

A page with Normal margins and Narrow margins is shown in Fig.3-61. 
 

  Fig.3-60 Changing margins Fig.3-61 (a) Page with Normal margins (b) Page with Narrow Margins  
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DO YOU KNOW? 

A Webpage is a document which 

can be displayed in a web browser 

such as Google Chrome, Internet 

Explorer or Edge. These are also 

often called just "pages." A 

collection of webpages are grouped 

together to from a Website. 

3.1.15 USING HYPERLINK 

Hyperlink is text in a Web page or document that links 

to another Web page or another place in the same document 

when the user clicks on it. 

The following are the steps to create a Hyperlink. 

1. Select the text that is to be displayed as Hyperlink as 

shown in Fig.3-62. 

  Fig.3-62 Inserting a Hyperlink  
 

2. Click the Insert tab. 

3. Click Hyperlink in the Links group as shown in Fig.3-63. 

4. Click OK. 

There is also an easy way to create a Hyperlink to Web page. Type the Hyperlink text and 

press Spacebar or Enter key. 

Hyperlink appears in blue color and underlined. To open the Web page, position the mouse 

pointer over the Hyperlink and press the Ctrl key while clicking the mouse button. 

The text format of Hyperlink can be formatted to regular text, that is, it should not be in blue 

color or underlined. To remove the text format of Hyperlink, Right-click the Hyperlink and select 

Remove Hyperlink from the shortcut menu. 
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Fig.3-63 Opening screen of Microsoft Excel 

3.2 SPREADSHEET 

Spreadsheet is used to store, organize, calculate and present numerical data in an easily 

understandable format. 

3.2.1 INTRODUCTION TO SPREADSHEET 

A spreadsheet is a grid of rows and columns in which user enters numbers and text. 

Spreadsheet programs are powerful multipurpose calculators, capable of everything from adding 

two plus two to solving problems that involve complicated calculations. Spreadsheet programs 

allow user to organize data, perform calculations, draw graphs of numeric data and develop 

professional looking reports. 

A common spreadsheet program is Microsoft Excel. It is a part of Microsoft Office 2010 

software. Therefore, use of Microsoft Excel 2010 will be explained. 

Opening the Microsoft Excel Program 

The following are the steps to open the Excel program. 

1. Turn on the computer and click Start button. 

2. Click All Programs. 

3. Click Microsoft Office to display the submenu. 

4. Click Microsoft Excel 2010 to open the Excel program. The opening screen of Excel will 

appear as shown in Fig.3-63. 
 

Identifying Cells 

The boxes formed by the intersection of individual rows and columns are known as cells. 

Cells are identified by the combination of their column letter and row number. For example, the 

sixth cell in the third column is known as cell C6. This is known as cell’s address. 

DO YOU KNOW? 

Microsoft was founded by Bill Gates and 

Paul Allen in April, 1975. 
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Fill Handle 

Active Cell 

At any moment user is positioned in a single cell known as active cell or current cell. Active 

cell has dark border as shown in Fig.3.63. When the user enters data, it goes in this cell. 

Excel Workbook 
Sheet Tabs 

When user starts Excel, it creates a new blank 

workbook, called Book1. A workbook contains sheets, 

each of which is called a worksheet. Excel opens a 

workbook with three worksheets as shown in Fig.3- 

64. 
 

 

 
  Fig.3-64 Sheets of Excel workbook  

 

Size of Spreadsheet 

DO YOU KNOW? 

Tip: You can rename a worksheet. For this, right click the 

sheet tab of the worksheet that you want to rename, select 

Rename in the shortcut menu, type a name and press Enter. 

Each worksheet in a workbook has 16,384 columns and 1,048,576 rows. Work area is like 

a movable window. The user can move the window sideways to view additional columns as well 

as up and down to view additional rows. 

Filling Columns and Rows 

The following are the steps to fill a series of numbers from 1 to 7. 

1. Enter 1 in cell A1 and 2 in cell A2 below it. 

2. Select the two cells, position the mouse pointer on the fill handle at the bottom right corner 

and drag it downwards through A7. 

3. The cells will be filled with series from 1 to 7. 

4. You can open the drop-down menu at the bottom right corner as shown in Fig.3-65 and select 

another option. 

 

  Fig.3-65 Filling a series in cells in rows  
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Fig.3-66 Filling cells with odd numbers in columns 

Fig.3-67 Entering formula in worksheet 

Cells are filled with odd numbers in Fig.3-66 by entering 15 in cell A3 and 17 in cell B3 and 

then dragging the fill handle to cell F3. 
 

Relative Cell Addressing 

In Excel, cell addresses included in a formula or function are relative cell addresses. 

Relative cell address means when a formula is copied to other cells, the cell references in the 

formula change to reflect the formula’s new location. 
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To understand relative addressing, consider the worksheet shown in Fig.3-67. 

 Enter the formula =B5+C5+D5 in cell E5 to calculate the total number of Acer laptop 

computers sold in the first quarter. 

 Copy the formula in cell E6. 

 The formula in cell E6 

becomes =B6+C6+D6 as 

shown in Fig.3-68. 

 The cell references have 

automatically changed based 

on the relative position of row 

and columns because relative 

cell addressing is used in 

formula in cell E5. 

 Similarly, the formula will 

become =B7+C7+D7 in cell 

E7   and   in   cell   E8   it  will 

become  =B8+C8+D8. This is 
  Fig.3-68 Copying formula to another cell  

 

 
Absolute Cell Addressing 

what is required in this 

worksheet. 

User can address a particular cell location no matter where the formula appears by 

using absolute cell address. Absolute cell addressing keeps a cell reference constant when 

copying a formula or function. Absolute cell addresses begin with a dollar sign in the formula, 

such as =$C$5 + $D$5. 

 

  Fig.3-69 Using absolute cell addressing in formula  
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Fig.3-71 Using Paste Special command 

In the worksheet of Fig.3-69, sales tax is calculated as 6% for software items. Absolute cell 

addressing is used for the cell C3 in the formula =C6*$C$3 in cell D6 for calculating sales tax 

because it should not change when the formula will be copied to cells D7, D8 and D9 as shown 

in Fig.3-70 . 
 

 
Paste Special 

  Fig.3-70 Copying formula that has absolute addressing  

Excel copies all the information in the selected range of cells when you paste data. Excel’s 

Paste Special command allows many 

other options while pasting cells such 

as paste only formats of selected cells 

without contents or paste contents 

without formulas. 

The following steps describe the use of 

Paste Special command. 

1. Select the cell range to paste. 

2. Open the Paste drop-down menu in 

Clipboard group of Home tab and 

select Paste Special as shown in 

Fig.3-71. Paste Special dialog box 

will open. 
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3. Select an option from the Paste Special dialog box shown in Fig.3-72 and click OK. 
 

  Fig.3-72 Paste Special dialog box  

 
 

 

  Fig.3-73 Formula in cell D6 is formatted  

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 Fig.3-74 Formula in cell D6 is copied to cell D7, D8 and D9 

Commonly used options of Paste 

Special dialog box are explained 

below. 

All: Used to paste all the information in 

the selected cell range. This is same as 

normal paste command. 

Formulas: Used to paste text, numbers 

and formulas without formatting. 

The formula in cell D6 in the 

worksheet shown in Fig.3-73 is 

formatted. When this formula is copied to 

cells, D7, D8 and D9 using paste special, 

the format of cell D6 is not copied as 

shown in Fig.3-74. 

Values: Used to convert formulas in the 

selected cell range to their calculated 

values and then apply the paste 

command. 

Formats: Used to paste only the 

formatting of selected cell range without 

cell contents. 
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All except borders: Used to paste all the information in the selected range without copying any 

borders if used. 

3.2.2 WORKING WITH FUNCTIONS AND FORMULAS 

Working with Functions 

Functions are built-In formulas in Excel that allow user to easily perform common 

calculations on data. Functions can be entered in a worksheet using keyboard, Insert Function 

command or AutoSum drop-down menu. 

 Using Keyboard to Find Average 

The following are the steps to calculate average sale for Acer laptop computer during the 

first quarter using the AVERAGE function. 

1. Select cell E5 where the result will appear. 

2. Type =av to display the Formula AutoComplete list as shown in Fig.3-75. 
 

  Fig.3-75 Calculating average  

3. Point to AVERAGE function and Double-click. 

4. Select the range B5:D5 to insert it as argument to the AVERAGE function. 

5. Press Enter key. 

 Using Insert Function command to Find the Highest Value 

The following are the steps to find the highest value. 

1. Select cell B11 where the answer will appear. 

2. Click Insert Function command shown in Fig.3-76. Insert Function dialog box will be 

displayed. 

3. Select MAX in the function list and click OK. 
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Insert Function command 

4. Type B5:B8 in the Number 1 text box of Function Arguments dialog box and click OK. 
 

  Fig.3-76 Using Insert Function command to insert a function  

 

 Using AutoSum Drop-down Menu to Find 

the Lowest Value 

The following are the steps to find the lowest 

value in the range B5:B8 using AutoSum drop- 

down menu. 

1. Select cell B12 where the answer will appear. 

2. Click Formulas tab. 

3. Open the AutoSum drop-down menu in the 

Function Library group as shown in Fig.3-77 

and select Min. 

4. Type the range B5:B8 and press Enter. 

Working with Formulas 

A formula is an expression that performs 
  Fig.3-77 Using AutoSum command  calculations. It consists of operators, constants and 

cell addresses. The standard operators used in Excel formulas are given in Table 3-78. 
 

Arithmetic Operation Excel Operator 

Addition + 

Subtraction . 

Multiplication * 

Division / 

Exponent ^ 

    Table 3-78 Arithmetic operators used in Excel  
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All the Excel formulas begin with equal sign (=) just like functions. For example, to 

multiply two numbers 4 and 7, the 

formula will be =4*7. User can also use 

cell   addresses  in   formulas   such as 

=(A4+B4)/5. This formula will first add 

the contents of cell A4 and B4 and then 

divide the sum by 5. 

Following are the steps to calculate 

the total number of laptop computer sale 

for the months of January, February and 

March in the worksheet shown in Fig.3- 

79.  Fig.3-79 Using formula to find sum  

1. Click cell B9 where the answer will appear. 

2. Type the formula =B5+B6+B7+B8 as shown in Fig.3-73 and press Enter. 

3. To calculate the total number of laptop computers sold in the months of February and March 

copy the formula from cell B9 to C9 and D9. 

4. Click the cell B9, point to the fill handle and drag it through cell D9. 

The user can also calculate the total number of laptop computers sold in January by 

performing the following steps. 

1. Click cell B9. 

2. Click Formulas tab. 

3. Double-click the AutoSum command in the Function Library group. 

Excel Automatically Recalculates Formula Results 

Whenever the user changes the value in a cell, the result of the formula in which that value 

is used will be automatically updated. This feature known as automatic recalculation is one of 

the main advantages that spreadsheets have over calculators. 

3.2.3 GRAPHICAL REPRESENTATION OF DATA 

A chart is used to 

represent data graphically. 

Charts are very helpful in 

explanation and representation 

of data. A commonly used chart 

is the column chart. Therefore, 

creation of this chart will be 

described for the worksheet 

shown in Fig.3-80. 
  Fig.3-80 Half yearly sale of laptop computers  
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Fig.3.82 Column chart 

 
Tip: To select a predefined chart 

style, click the chart that you want 

to format. This will display Chart 

Tools. On the Design tab, in the 

Chart Style group, select the chart 

style. 

Creating a Column Chart 

The following are the steps for creating a column chart. 
 

  Fig.3-81 Selected cell range for column chart  

 

 
The chart shown in Fig.3-82 will appear on the screen. 

 
 
 
1. Select the cell range (source data) 

as shown in Fig.3-81 that you 

want to represent in the column 

chart. 

2. Click Insert tab. 

3. In the Charts group, open the 

drop-down menu of Column 

command. 

4. Select a chart from the menu. For 

example, the chart on the top left 

corner of menu. 

 
 
 
 
 
 
 
 

 

Following are the steps to give 

titles to the chart and horizontal 

and vertical axis to make it 

more meaningful. 

1. Click anywhere in the 

chart to make the Chart 

Tool tabs appear in the 

Ribbon. 

2. Click Layout tab as 

shown in Fig.3-83. 
 

 

  Fig.3-83 Layout tab of Chart Tools  

Tip: To only print the chart in a 

worksheet, click anywhere in 

the chart and give the print 

command. 
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3. Click Chart Title in 

Labels group and select 

Above Chart. 

4. Type the chart title in the 

text box. 

5. Click the Axis Titles 

command, select 

Primary Horizontal 

Axis Title and select 

Title Below Axis. 

6. Type the horizontal axis 

title in the text box. In the 

same way give a title to 

the vertical axis. The 

resulting chart is shown 

in Fig.3-84 

 

 

  Fig.3-84 Column chart after labelling  

 

3.2.4 MANIPULATING AND FORMATTING DATA 

Filtering Data 

Filtering data means displaying 

only the information that the user 

needs based on a condition. For 

example, user could filter a list of 

students for viewing who belong to a 

particular class. User could also 

filter a list of people whose ages are 

above 30. 

The following are the steps to filter a 

list of students who belong to class 

IX.B. 

1. Select the rows you want to filter 

including the header row as shown 

in Fig.3-85. 

2. Select the Data tab on the Ribbon. 

 
  Fig.3-85 Data selected for filtering  

3. Click the Filter command in the Sort and Filter group. 

4. Drop-down arrows will appear in the header of each column. 
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  Fig.3-86 Selecting filter condition  
 

Data Validation 

5. Click the drop-down arrow for class column. The 

filter menu will appear as shown in Fig.3-86. 

6. Uncheck the boxes next to (Select All), IX.A and 

IX.C. 

7. Check the box next to IX.B. 

8. Click OK. Only the information of students who 

belong to class IX.B will be displayed. The other data 

will be temporarily hidden. 

The following are the steps to clear the filter. 

1. Click the drop-down arrow in the Class column. 

2. Click Clear Filter From “Class”. 

3. Click Filter Command in the Ribbon. 

Data validation is used to control the values or the type of data that user enters into a cell. 

The following steps will define criteria for entries in class column of student worksheet to 

IX.A, IX.B and IX.C. If the user enters any other data, an error message will appear. 

1. Create a list of valid entries in the worksheet that contains the data IX.A, IX.B and IX.C. 

2. Select all the cells in Class columns without the column header. 

3. Click the Data tab on the Ribbon as shown in Fig.3-87. 
 

  Fig.3-87 Using Data Validation command  
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4. Click Data Validation 

command in the Data Tools 

group. Data Validation dialog 

box shown in Fig.3-88 will 

appear. 

5. Click the drop-down arrow 

below Allow heading and select 

List. 

6. Click the button on the right side 

below Source. 

7. Select the cell range that 

contains the list of valid entries 

and click Close. 

8. Click OK to apply validation. 

As another example, restrict 

data entries in the Age column to 

ages between 13 to 17. 

1. Select all the cells in Age 

column without the column 

header. 

2. Click Data tab on the Ribbon. 

3. Click Data Validation command 

in the Data Tools group. Data 

Validation dialog box will 

appear. 

4. Click the drop-down arrow 

below Allow. 

5. Select Whole number from the 

menu as shown in Fig.3-89. 

 

 
 

 
 

 

  Fig.3-89 Data Validation dialog box  

6. Enter 13 for the minimum value and 17 for the maximum value. 

7. Click OK to apply validation. 

Protecting a Worksheet 

When a worksheet is protected, other users can only view the information in it but changes 

cannot be made. 

The following are the steps to protect a worksheet. 

Fig.3-88 Data Validation dialog box 
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1. Click Review tab in the Ribbon. 

2. Click Protect Sheet command in the Changes group. 

3. Enter a password and click OK. 

4. Reenter password to confirm and click OK. 

Unlocking Cells 

Generally the user would not like to prevent changes to the entire worksheet. The user may 

want to allow other users to make 

changes in worksheet data but 

prevent changes to titles and 

formulas. For this, unlock the cells 

in which data editing is to be 

allowed. 

The following are the steps to 

unlock cells. 

1. If your worksheet is protected, 

click the Unprotect Sheet 

command in the Changes 

group on the Review tab. 

2. Select the cells you want to 

unlock. 

3. Press    Ctrl+1    to    open the 

Format  Cells  dialog box and 

  Fig.3-90 Format Cells dialog box  click the Protection tab as 

shown in Fig.3-90. 

4. Click the Locked check box to remove its check mark and click OK. 

5. Protect the worksheet as explained earlier. 

Conditional Formatting 

Excel provides commands to apply formatting to one or more cells based on the value of the 

cell. This is known as conditional formatting. User can apply one or more rules to cells such as 

if the value in the cell is less than 33 then color the cell red. The advantage of applying such 

rules is that the user can easily view which cells have value less than 33. 

The following steps will 

color the text red with light 

red background in cells 

that have value less than 

33 in the worksheet shown 

in Fig.3-91 

  Fig.3-91 Result sheet of students  
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1. Select the cells to which you want to apply conditional formatting. 

2. Click Home tab on the Ribbon. 

3. Click Conditional Formatting command in Styles group to open the drop-down menu and 

select Highlight Cells Rules as shown in Fig.3-92. 
 
 

 
Less Than command 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  Fig.3-92 Conditional Formatting  

 

4. Select Less Than in the submenu. 

5. Enter 33 and select Light Red Fill with Dark Red Text in Less Than dialog box to view the 

failing marks in red color with light red background as shown in Fig.3-93. 

6. Click OK to apply the formatting. 
 
 
 
 

  Fig.3-93 Worksheet after conditional formatting  
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Fig.3-94 Opening Inpage 

Program 

Paragraph 
Align 
Tool Bar 

Graphical 
Shapes 
Tool Bar 

Document Window 

Vertical 
Ruler 

3.3 URDU EDITOR 

3.3.1 INTRODUCTION TO INPAGE URDU EDITOR 

Inpage is widely used Urdu language editor introduced in 

1994. It runs on Windows operating system and it is used for creating 

documents in Urdu/Arabic languages, etc. It provides all the standard 

formatting and editing tools available in word processors used for 

creating documents in English. It is easy to learn and use. Inpage 

allows user to create wide variety of documents such as letters, 

reports, books, magazines, newspapers and brochures in Urdu. Urdu 

word processing is now available in MS Word. That option may be 

used. Next year you may learn MS Word Urdu using the language 

bar in windows 7 onward. The language shift programming is called 

localization. It was done by National Language Authority Pakistan 

and Inksoft, Islamabad under the guidance of Dr. Attash Durrani. 

Opening the Inpage Program 

The following are the steps for opening the Inpage program. 

1. Turn on the computer and click Start button. 

2. Click All Programs. 

3. Click Inpage 2009 Professional to display the submenu. 

4. Click Inpage 2009 as shown in Fig.3-94. The opening screen of Inpage will appear as shown 

in Fig.3-95. 

Title Bar Menu Bar Formatting Tool Bar Horizontal Ruler 

  Fig.3-95 Opening Screen of Inpage Urdu Editor  
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Fig.3-99 Keyboard Preference dialog box to select 

a keyboard 

3.3.2 MANAGING A DOCUMENT IN INPAGE 

Creating a New Document 

1. Click the File tab. 

2. Click New in the pull-down 

menu as shown in Fig.3-96. 

3. New Document window will 

appear as shown in Fig.3-97. 

4. Set the Page, Margins and 

Columns setting and click 

OK. 

5. Now, type the text in Urdu. 

Selecting a Keyboard 
Layout 

1. Click Edit to open 

the Edit pull-down 

menu. 

2. aClick 

Preferences to 

open the submenu 

and select 

Keyboard 

Preferences as 

shown in Fig.3-98. 

  Fig.3-96 File tab    Fig.3-97 New Document window  

 

 

3. Select a keyboard 

from the Keyboard 

Preferences 

window shown in 

Fig.3-99 and click 

 
 
 
 
 
 

  Fig.3-98 Selecting a keyboard layout  
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OK. User can also view the keyboard layout as shown in Fig.3-100 by clicking the view 

option. 
 
 
 
 

(a) 
 
 
 

 

(b) 
 

  Fig.3-100 Keyboard layout of (a) Monotype and (b) Phonetic Keyboard  
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Opening a Document 

1. Click the File tab. 

2. Click Open. The Open Document dialog 

box shown in Fig.3-101 will appear. 

3. Select the document 

4. Click Open. 

An Urdu document prepared in Inpage 

program is shown in Fig.3-102. 

  Fig.3-101 Open Document dialog box.  

  Fig.3-102 Urdu document  

Saving a Document 

1. Click File tab. 

2. Select Save or Save as. Save Document 

As dialog box shown in Fig.3-103 will 

appear. 

3. Select the folder where document is to be 

saved. 

4. Give a file name to the document. 

5. Click Save. 

3.3.3 FORMATTING DOCUMENT 

Copying or Moving Text   Fig.3-103 Save Document As dialog box  

1. Select the text to copy or move by dragging the mouse pointer. The selected text will be 

highlighted. 

2. Click Edit to open the Edit pull-down menu as shown in Fig.3-104. 

3. Select Copy or Cut. 
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Fig.3-104 Text selected for copying 

4. Position the mouse pointer at the location where the text is to be copied or moved. 

5. Open the Edit menu and click Paste. 
 

The shortcut commands Ctrl+C, Ctrl+X and Ctrl+V can also be used for Copy, Cut and 

Paste respectively. 

 

  Fig.3-105 Document after copying the text  
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Deleting Text 

To delete text, select the text as shown in Fig.3-106 by dragging the mouse pointer and 

then press the Delete key. 
 

  Fig.3-106 Text selected for deletion  
 
 

  Fig.3-107 Document after deleting the text  
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Changing Language 

The following are the steps for changing to English language. 

1. Click Language in Menu Bar as shown in Fig.3-108. 

2. Click Toggle Language. 

3. Perform the same steps to return back to Urdu typing. 

 
 

 
Language Menu 

  Fig.3-108 Changing language  
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Formatting Text 
 
 

 

  Fig.3-109 Text Formatting Tools  

Select the text and apply the appropriate commands given in Fig.3-109. Text with different 

formatting is shown in Fig.3-110. 
 
 
 

  Fig.3-110 Formatted text  
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  Key Points  
 

 Word processing refers to the use of computer to create, edit, format and print documents. 

 A word processor is computer application software that is used for the creation of 

documents on computer. 

 Ribbon is located below the title bar of Word window and it consists of tabs, groups 

and commands. It provides access to commands that are needed while working on a 

document. 

 Page break is a marker that tells Word program that the contents which follow are to appear 

on a new page. 

 Section break inserts a new page but it allows the user to change the page format without 

having any effect on the formatting of the previous pages. 

 Header refers to information that appears at the top of a page and footer to information that 

appears at the bottom of a page. 

 WordArt is a text modifying feature in Word to create decorative effects such as shadow, 

colors, 3D effects, changing shape of text, etc. 

 Hyperlink is text in a Web page or document that links to another Web page or another 

place in the same document when user clicks on it. 

 Spreadsheet is a grid of rows and columns in which user enters numbers and text. 

 A workbook consists of sheets, each of which is called a worksheet. Excel opens workbook 

with three sheets but user can add additional worksheets if required. 

 Relative cell address means when a formula is copied to other cells in Excel, the cell 

references in the formula change to reflect the formula’s new location. 

 Absolute cell addressing keeps a cell reference constant when copying a formula or 

function. 

 A chart is a used to represent data graphically. It helps in explanation and communication 

of the meaning of data in a worksheet. 

 Filtering data means displaying only the information that is needed based on a condition. 

 Data validation is used to control the values or the type of data that user enters into a cell. 

 Conditional formatting means applying a particular format to one or more cells based on 

the value of the cell. 
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  Exercise  
 

Q1. Select the best answer for the following MCQs. 

i. Which of the following software is used for creating professional documents? 

A. Spreadsheet Software B. Word processor 

C. Typing Tutor D. Both A and B 

ii. Which of the following tab of Word Ribbon contains Clipboard group? 

A. Page Layout B. Insert 

C. File D. Home 

iii. By default how many tabs are there in Word Ribbon? 

A. 7 B. 8 

C. 9 D. 10 

iv. What is used for creating decorative effects in Word? 

A. Paragraph formatting B. Text formatting 

C. Page formatting D. WordArt 

v. Which of the following tab contains the commands for creating charts in Excel? 

A. Home B. Formulas 

C. Insert D. Data 

vi. Which of the following command in Excel allows the user to view only certain data in a 

worksheet based on a condition? 

A. Data validation B. Data filtering 

C. Conditional formatting D. Data manipulation 

vii. Which of the following command in Excel restricts user from entering wrong data in cells 

of a worksheet? 

A. Data validation B. Data Filtering 

C. Conditional formatting D. Data manipulation 

viii. Which of the following command is used to apply formatting to one or more cells based 

on the value of the cell? 

A. Data validation B. Data filtering 

C. Conditional formatting D. Data manipulation 

ix. Which of the following shortcut keys are used for pasting selected text? 

A. Ctrl+C B. Ctrl+X 

C. Ctrl+V D. Ctrl+P 

x. When the mouse pointer is at extreme left and changes to a right-pointing arrow, which 

of the following command is used in Word to select the entire document? 

A. Double-click B. Triple-click 

C. Ctrl+Single-click D. Shift+Single-click 
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1. Type the following text and apply the commands given at the end. 

COMPUTER ETHICS 

Computer ethics is concerned with the moral guidelines for the ethical use of computer 

technology. It emerged with the invention of computer. It specifies what is right and what 

is wrong when using computer technology. The following are some important points of 

computer ethics. 

Computer should not be used to harm other people 

Computer should not be used to commit any type of crime 

Computer users should not create computer virus 

a. Center the title and make it bold 

b. Apply font size 16 to the title 

c. Justify the paragraph 

Q2. Write short answers of the following questions. 

i. What is a word processor? Write some advantages of it over a typewriter. 

ii. Name any three types of documents which can be prepares in Word. 

iii. Differentiate between page break and section break. 

iv. Why header and footer are important in a Word document? 

v. What is the purpose of control buttons in Word window? 

vi. Why hyperlinks are created in Word document? 

vii. Name any three areas of application of Excel. 

viii. Differentiate between relative and absolute cell addressing in Excel. 

ix. What are the advantages of protecting an Excel worksheet? 

x. How graphical representation of spreadsheet data can be helpful in business. 

Q3. Write long answers of the following questions. 

i. Which shortcut keys are used in Word to move cursor to the beginning of line, end of line, 

top of the document and end of the document? 

ii. Write the mouse commands used for selecting various items is a Word document such as 

single word, sentence, paragraph, etc. 

iii. Explain text and paragraph formatting in Word. 

iv. Describe the Paste Special command used in Excel. 

v. Describe how functions are used in Excel with examples. 

vi. Describe how formulas are used in Excel with examples. 
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d. Underline and bold the words “Computer ethics” in the paragraph 

e. Apply italics and bold to the words “computer technology” 

f. Apply bullets to the last three lines 

2. Create weekly timetable of your class in Word and give title to it using WordArt. 

3. Create the following worksheet in Excel and calculate sum and average using 

formulas. 
 

Expenses of 1st Quarter 

S.No. Expense Jan Feb Mar Total Average 

1. Salary 87000 102400 113800   

2. Rent 2500 2500 2500   

3. Utilities 3250 3500 3080   

4. Transport 7830 6885 8940   

5. Miscellaneous 4500 6708 7740   

4. Create a column chart for expenses in the months of January, February and March 

for the above worksheet. 

5. Create the following worksheet in Excel and enter marks in the subject columns in 

the range 0 to 75. Restrict data entries in the subject columns to the specified range 

using data validation command. 
 

S.No. Student Name Mathematics Physics Computer Chemistry 

1. Abrar Nabi     

2. Mumtaz Akbar     

3. Muhammad Bilal     

4. Javed Akhtar     

5. Afzal     

6. Muslim Khan     

6. Write a leave application in Urdu using the Inpage Urdu editor. 


